VMware Application Dependency Planner (ADP)

is a free tool for channel partner, in order to access to the tool you need to email our special alias:
services-software-support@vmware.com

ADP is a great tool to provide automated, real-time application discovery and dependency mapping to accelerate DC migration, but due to the complexity of the tool the team will usually ask you a couple of questions to qualify your background before they can provide you the links to the ADP software, to give you a heads up some of the sample questions you will get asked are:

1. What will the software be used for? E.g. Customer engagement, just trying out/testing, provide it to a partner.
2. Do you or the person(s) who is going to use the software have experience with ADP? If yes explain.
3. Do you or the person(s) who is going to use the software have knowledge of networking concepts? In particular: span ports, network protocols such as netflow, understanding of different types of switches both physical and virtual?

You can find an ADP 1.0 training at: http://mylearn.vmware.com/mgrReg/courses.cfm?ui=sso&a=det&id_course=165819

Here are the ADP download links, we would appreciate it to notify us when you’re done downloading. And please go through the documentation carefully.

To deploy ADP with embedded database in Aggregator:
ADP Core OVA 2.0.0.1: http://ftpsite.vmware.com/download/rlspsrl/ADP/2.0.0.1/Application-Dependency-Planner-2.0.0.1-2180573_OVF10.ova

To deploy ADP with database in an external vPostgres appliance:
ADP Core OVA 2.0.0.0: http://ftpsite.vmware.com/download/rlspsrl/ADP/2.0/Application-Dependency-Planner-2.0.0.0-1446518_OVF10.ova

After deploying ADP core appliance, please install the shell shock patch by logging into appliance as root and follow instructions described in document http://ftpsite.vmware.com/download/rlspsrl/ADP /2.0/ADP-shell-shock-update.pdf

There is a known OpenSSL libray compatibility issue in the latest ADP 2.0.0.1 build, which prevents configuring external vPostgres database and also doing SSH. The work around is to use ADP 2.0.0.0 and run the shell shock security patch manually to bring it up to ADP 2.0.0.1 level. The only change made in ADP 2.0.0.1 is patching the appliance for shell shock security issue.

vPostgres OVA to be used with ADP 2.0.0.0 core appliance:
http://ftpsite.vmware.com/download/rlspsrl/ADP/2.0/VMware-vFabric-Postgres-appliance-9.2.9.1-2170145_OVF10.ova

OLAP Scripts:
http://ftpsite.vmware.com/download/rlspsrl/ADP/2.0/adm_olap-2.0.0.0-1446518.zip
Best regards,
Anton Sabev
VMWare Field Tools Support Team

04/07/2015 22:10 – Roshan Ratnayake wrote:
Hi VMware

I would like to request access to the Application Dependency Planner (ADP) for a upcoming client engagement to assess current state environment and documentation.

1. What will the software be used for? E.g. Customer engagement, just trying out/testing, provide it to a partner.
a. assess current state environment and documentation
2. Do you or the person(s) who is going to use the software have experience with ADP? If yes explain.
a. No specific with the VMware tool, but similar tools from BMC
3. Do you or the person(s) who is going to use the software have knowledge of networking concepts? In particular: span ports, network protocols such as netflow, understanding of different types of switches both physical and virtual?
a. Yes, this will be used by Senior Consultants with extensive VMware and Networking experience.
Training – VMware Partner University – do a search on ADP you should able to review the VoD.

SPAN/RSPAN so that we can mirror the proper traffic

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s